Appfarm Create is Unavailable

Incident Report for Appfarm AS

Postmortem

Incident Summary

On February 9, 2026, Appfarm Create experienced a disruption starting at 02:20. The issue was caused by an internal platform service lacking the necessary permissions following an accelerated rollout. While the technical failure occurred early in the night, the service was not restored until 13:05. This delay was primarily due to a failure in operational routines, which meant that the resulting system alerts were not addressed in a timely or effective manner.

Root Cause

The incident was the result of two main factors:

  1. Permission Gap: A rapid deployment of platform updates led to a configuration error where an internal service didn't have the correct access levels. This caused Appfarm Create to fail.
  2. Operational Routine Failure: There was a breakdown in our routines for monitoring and responding to system health. Alerts were triggered, but they were not acted upon early enough and routines not followed.

Detection and Resolution

The technical issue persisted through the night and morning hours. Once the operational routines were caught up and the alerts were properly evaluated, the team identified the permission gap. The incident was resolved at 13:05 by correcting the access rights for the internal platform service, immediately restoring functionality of Appfarm Create.

Preventive Measures

To improve our resilience and response times, we are focusing on the following:

  • System and Routine Optimization: We are working on a more robust framework for our internal alerting system and operational routines.

We sincerely apologize for the inconvenience this incident caused. We are committed to providing reliable service and are using this experience to strengthen our processes and infrastructure.

Posted Feb 09, 2026 - 15:12 CET

Resolved

This incident has been resolved.
Posted Feb 08, 2026 - 13:55 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 08, 2026 - 13:03 CET

Investigating

We are currently investigating this issue.
Posted Feb 08, 2026 - 12:39 CET
This incident affected: Appfarm Create.